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Lab 4 ESRM430 

Instructor: Dr. L. Monika Moskal 

 

 

Lab Objectives: 

 Introduction to SPRING software  

o Simple image manipulation and analysis 

o Computer aided image segmentation 

 

Tools/Data: 

 SPRING Software -- version 5.2.7  

 Sample of the 1996 aerial panchromatic image of the Washington State Arboretum area at 0.5m per pixel resolution 

with image dimension of 2184 by 1812 pixels --- file name: arboretum.jpg 

 Sample of the November 9, 2007 true color image of UW campus at 0.37m per pixel resolution and image dimension 

of 920 by 920 --- file name: UWvista.jpg 

 Spring Software Manual by the USFWS (2006) is available on the class website 

 Additional Tutorials and information is available on the SPRING software developer site : 

http://www.dpi.inpe.br/spring/english/ 

 Lots of patience  

 

What you will hand in: 

 This lab will be submitted in a digital format using the Labs drop box on the course website 

 A written discussion with screen captures of maps imbedded directly in a word document. 

_____________________________________________________________________________________________ 

 

Task 1:  

 Set up a directory on the computer to work from. I suggest creating a folder on the desktop titled ERM430_Lab 

 Download the Lab 4 ZIP file to your computer and decompress it 

 Do not work form your flash drive, but do back up the lab folder you have been working in to the flash drive at the 

end of the lab 

 

 Note for those using the software on their own computers: SPRING can be unstable in versions of the windows 

operating system other than Windows XP or Vista, if you are going to use the software on your computer, you might 

need VMWARE or other operating system emulating software switch your operation system into Windows XP in 

order to run the SPRING software correctly. 

 

Task 2: 

The Spring 5.2.7 software has already been installed on your lab computer. The software is free and can be used on any 

computer you have permission to install programs on. It can be acquired from the link above or the link on the class website. 

 

Task 3: 

In this task you will import the 1996 panchromatic image to work with in the SPRING software. Note the image does not 

have geocoordinates. We are only working with it as an example and will not be setting appropriate geographic coordinates 

for the image. If you were to use this software for a project you can either spend a substantial amount of time prepping to set 

up the imagery for import with geographic coordinates, or you can post- rectify the results using the same control point data 

that you would use to georectify the image. Another recommendation is to convert your image to a JPG (you can do this in 

any photo analysis software such as Adobe Photoshop); imports of GeoTIFF to SPRING is problematic but if you want 

information on this see the note on 'Import/Export at the end of this lab. In this lab we simplify the import process by working 

with ‘jpg’ file format which does not have geographic coordinates, because we will not be exporting this data to GIS or using 

any other additional GIS data layers in this project.  
 

 
 

 

http://www.dpi.inpe.br/spring/english/
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Step A: 

 Start the SPRING 5.2.7 (English) software 

 The Database window will open automatically for a new project, if it does not in 

the main menu go to File>Database and create a database with the name 

“Lab4_1996photo”; the database type should be SQLite (the Manager drop down 

box). Click Create. 

 You will be prompted to create a password for your database, choose no unless 

you want one, it is not required. 

 Hit the Apply button. If the dialogue box does not close on its own click Close to 

exit the database dialogue box 

 

Step B: 

 Next go to File>DataModel and create a new data model.  

 To do so, in the Name field give the model a name such as “AerialPhoto" 

 For this exercise choose the Image type Data Model by clicking the image radio 

button in the Data Model box 

 Hit the Create button and then the Execute button 

 Select “AerialPhoto” and check that in the Table field a table has been defined: 

CG000007 before you close this dialogue box 

 

Step C: 

 Next import the 1996 photo by going to File>Import>Import Vectorial and 

Matricial Data  

 In the Import window click File and navigate to the folder with the arboretum.jpg 

image (you may have to change the file type from .spr to .jpg for your image to 

appear). 

 Select the image (arboretum.jpg) you copied from the lab website or drive 

 Entity should be set to Image 

 Enter the resolution as X: 0.5, Y: 0.5 (0.5 m pixels) 

 Click on the Projection button and set the projection to NO PROJECTION and 

click Apply 

 Click the Bounding box button and enter the coordinates below in their 

corresponding fields, after you are finished click Apply: 

 X1 0.0  

 X2 2184 

 Y1 0.0 

 Y2 1812 

 We are not finished here! Do not close the “Import” window yet! If you do you will 

have to start from the beginning of this step. Continue to Step D before closing the “Import” window. 

 

Step D:  

 Next click the Output tab and name in the Project field name the project “Lab4_1996photo” 

 Click the Category button to change the model type from CAT_Image to AerialPhoto. Click Execute. 

 In the IL (info layer name) field name the image “arboretum”.  

 Hit the Apply button and then the Close the window 

 

  

It will appear that nothing has happened. Do not worry, move on to Task 4. 
 

 

 

 

 

 

 

 

 



Page 3 of 8 

 

Task 4: 

(8th color icon from the left on the main menu). Once you have imported the image open the Control Panel 

  

These are some other useful tools 

 

Draw:  

 

 

Navigation Tools: 

 

 

 Go to the Assistant Tab (2nd tab on the bottom of the software interface) 

 Click on your arboretum Infolayer "Image" in the Available Infolayers Tab 

 Since this is a monocromatic image (grayscale) you are selecting the M to display it (Located in the lower left 

hand corner). Color images would use the RGB display 

 Hit the Draw icon to display the image if the image does not appear 

 Use the navigational tools to zoom in on any areas of your liking, your only task here is to explore the image 

and to get comfortable with the navigation tools on the toolbar. 
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Task 5: 

To understand what pixel values in imagery represent and how some simple tools such as histograms can help us interpret 

them we will use the contrast tool.  

 

 For this step be sure to be zoomed out to the fullest extent of the image.  

 In the main menu go to Image>Contrast, a histogram will appear. 

  Now zoom into any area of the image, try to understand why the histogram changes when the view changes.  

 

Answer the following question: 

 

1. Describe the shape of the histogram for the full image. How does the histogram relate to the visual image that you 

are seeing? Also, screen capture the histogram and include it in your write up; to do so click on the Contrast window 

then press the following buttons together: Ctrl, Alt, Print Screen. This will save the window to the clipboard, you 

can now paste it to your word write up document. 

 

Now navigate the image so that one of the water areas is in the center of the screen and begin zoom in (+) and observe the 

changes in the histogram as you increase the resolution of the image. 

 

Answer the following questions: 

 

2. What happens to the histogram as you navigate around the image?  

3. If you were to center your display on one of the highway overpasses, what do you expect to see in the histogram? 

4. How about if you centered it on vegetation? 
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Task 6: 

Image filtering and enhancements allow us to better visually interpret an image.  

 

 In the main menu go to Image>Filtering… 

 Select the Edge Directional filter radio button. 

 In the Name field name the image Edge_Directional and click Apply. This will produce an Edge Direction image 

(you may have to zoom out to the fullest extent to see the image).  

 

Answer the following question: 

 

5. Include the Edge Directional image and discuss the Edge Directional image you created. 
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Task 7: 

In this next section you will be working with the UW vista 2007 true 

color image; this JPG image is not georectified.  

 

Step A:  
 Go to File>Database and create a new database with the 

name UW_2007. 

 Next import the UW vista 2007 true color image by  

File>Import>Import Vectorial and Matricial Data as we 

did earlier.  

 In the Import window click File and navigate to the folder 

with the UWvista.jpg image (again, you may have to change 

the file type from .spr to .jpg for your image to appear). 

 Select the image (UWvista.jpg) you copied from the lab 

website  

 Entity should be set to Image 

 Set resolution to X:0.37, Y:0.37 (0.37 meter pixels) 

 Click on the Projection button and set the projection to NO PROJECTION and click Apply 

 Click the Bounding box button and enter the coordinates below in their corresponding fields, after you are finished 

click Apply: 

 X1 0.0  

 X2 920 

 Y1 0.0 

 Y2 920 

 

Step B:  

 Click the Output tab and name in the Project field name the project “UWvista” 

 Keep the Category model type as CAT_Image. 

 Name the IL Image 

 Hit the Apply button and then the Close the window 

 

 Since this is not a monochromatic image you will need to set up the multicolor bands one by one to display the 

image in true color: Click the control panel icon  and highlight Image_r in the control panel and then click the R 

radio button to load the red band. Do this for the blue and green bands as well.  
 Explore the image, notice some of the taller buildings seem to be leaning. 
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Task 8: 

Segmentation relies on the pixel values and the spatial characteristics of an image. 

Although the algorithms used in segmentation are often proprietary they rely on the 

fundamental of spatial autocorrelation which we will discuss in class. 

In this final task you will produce 2 segmentations of the color image. The 1st 

segmentation will use the least number of similarity classes (3), the second segmentation 

will use a larger number of similarity classes (30).  

 

Step A: 

 

 In the main menu go to Image>Segmentation.  

 

*Set up the segmentations as per these instructions, using only one of the three color 

bands (red). We do this to speed up processing time and because we will not be 

working with near infrared or multispectral color imagery.  

 

 Your method should be Region Growing for both segmentations.  

 Select the Image_r band (the farther into the spectrum we go the less 

atmospheric interference in our data, thus, the red band has the least atmospheric 

impact) 

 Set Similarity to 3 (you will repeat this process with the setting of 30 for the 

second segmentation) 

 Set Area to 100 

 Give the Segmented Image a proper IL Name (i.e. - segment3 for the first and 

segment30 for the second). 

 Leave the remaining default settings (arc smoothing, bounding box). 

 Hit Apply. 

 

 

Step B:  

 

When the segmentation is complete the message below will appear, this tells you that your segmentation has finished and 

how much time it took to complete: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 Click on OK to close the message.  

 If you want to inspect the segmentation, highlight the segmentation infolayer in the Control Panel, click on the 

Labeled checkbox, and click on Draw or the Reset button on the main window command bar.  

 If you want the image displayed in the background of the segmentation load the bands as we did in earlier  

 You can save the segmentation images as JPEG’s in the main menu go to File>Save As JPEG Image… 

 

Repeat the above process with the Set Similarity of 30; this will produce a second segmentation for discussion and 

comparisons. You must reopen the “main” window to load the image again. Click on the main tab at the bottom to do this.  

 

Answer the following question: 

 

6. Discuss the differences in the segmentations you produced.  
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Import/Export with SPRING 

 

 

 

Image Imports to SPRING 5.2.7 

SPRING can import various formats of imagery but we have found that JPG (no georeference) and GeoTIFF images are the 

best candidates for import.  

 

JPG Import 

You can create JPG files using many image packages such as Photoshop and even PowerPoint. Make sure that you 

do not compress imagery during this process. You will lose all georeferencing once you convert an image such as 

a GeoTIFF to JPG. You can use the ground or other control points used during the registration of your imagery on 

all files that you export out of SPRING as long as these SPRING files are generated from the imagery and do not 

lose the spatial extent (same area) as the original image. This is the easiest work around to dealing with the 

georefrencing shortfalls in recent versions of SPRING. This is also an area of improvement that the developers of 

SPRING are working hard on and will continue to improve in the next versions of the software. 

 

 

GeoTIFF from ArcGIS Import 

ESRM ArcGIS software does not create world files that are required for the proper import of GeoTIFF images to 

SPRING unless a world file is generated for them. One solution is to use the 'geo tiff creator' program which is 

available at: 

http://www.remotesensing.org/geotiff/geotiff.html 

 

GeoTIFF from FUSIONImport 

Many segmentation projects relying on the SPRING software combine imagery and lidar generated raster data. 

One way to produce the lidar generated raster such as canopy density is with the use of  FUSION software. The 

world files generated with FUSION are not exactly the same as those generated in ArcMap and need to be 

corrected. You can do so by copying and pasting a world file for a GeoTIFF image from ArcGIS (or other 

software) and rename  it to match the FUSION file name. The assumption is that both datasets have the exact 

spatial extent. 

 

If you are using only FUSION generated GeoTIFF you should not have problems with incorporating these into 

SPRING through the GeoTIFF import. If you do consider using JPGS or generating the world files with the 'geo 

tiff creator' program. 

 

 

Exporting Shapefiles from SPRING 5.2.7 

The shapefile you export out of SPRING from a JPG based segmentation will not have any georeferencing and will need to 

be georectified. SPRING adds 10,000,000 units to all of the values in the Y axis, you will find this true on all shapefiels 

you export form SPRING. This can be corrected by using the Editor ToolBar and the Mover Tool in ArcMap, you will need 

to subtract 10,000,000 in the Y axis for all of the layers you need to line up with your original data. 


