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Lab 5 ESRM430 

Instructor: Dr. L. Monika Moskal 

 

Lab Objective: 

 Image classifications - Part 1 

Tools: 

 SPRING Software -- version 5.2.7 

 Olympia WA digital imagery (true and color near infrared) 

o Date: August 2008 

o Imagery size is 10,000 by 1,500 pixels and 0.1m per pixel. 

 Excel File: Lab5.xlsx  

 Lots of patience  

What you will hand in: 

 A Word document containing answers to questions in red, posted to the class dropbox 
_____________________________________________________________________________________________ 

 

Task 1:  Set up a directory  

 

 Set up a directory on the C drive to work from. I suggest using …ESRM430/Lab5 

 

 Download Lab 5 materials to your computer from the course website 

 

 Do not work from your flash drive, but do back up the lab folder you have been working with to the flash 
drive at the end of the lab 

 

 

Task 2: Open SPRING 

 

The SPRING 5.2.7 software has already been installed on your lab computer. The software is free and can be used on any 

computer you have permission to install programs on. It can be acquired from the class website.  

 

 Open the software by going to All Programs and navigate to the SPRING 5.2.7 folder and click on SPRING 

5.2.7  

 

Task 3: Create a Database, Data Model, and Import Imagery 

 

In this task you will create a database, like we did in Lab 4. You will import the true color and color near-infrared imagery 

on the course website (04406110_TC.TIF, 04406110_NIR2.TIF ) of Olympia, WA to work with in the SPRING software. 

Assume the imagery is not georectified. The steps below are the same as the creating a database, creating a data model, and 

importing imagery steps in Lab 4. 

 

Step A: Create a database  

 

 After opening SPRING the Database window will open 
automatically, if it does not in the main menu go to 

File>Database and create a database with the name “ Lab5”; the 

database type should be SQLite (the Manager drop down box) 

 

 You will be prompted to create a password for your database, 

choose no unless you want one, it is not required 

 

 Hit the Create and then Apply buttons. If the dialogue box does 

not close on its own click Close to exit the database dialogue 

box 
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Step B: Choosing a Data Model for the true color imagery 

 

 Go to File>DataModel and choose the CAT_Imade data model 

 

 Enter a name, in this example “ Image” 

 

 Hit the Create button and then the Execute button 

 

 

 

 
 

 

In the past lab you created a data model. This was to show you how to do this 

if you ever needed to in the future.  

 

 

 

 

 

Step C: Import the true color imagery (04406110_TC.TIF and 04406110_NIR2.TIF) 

 

 Import the imagery by going to File>Import>Import Vectorial and 

Matricial Data  

 

 In the Import window click File and navigate to the folder with the 

04406110_TC.TIF and 04406110_NIR2.TIF images (you may have to 

change the file type from .spr to TIFF/GEOTIFF(*.tif*.tiff) for your 

images to appear) 

 

 Select the image 04406110_TC.TIF  
 

 Entity should be set to Image 

 

 Set Resolution to 0.1 by 0.1  (0.1m pixels) 

 

 Click on the Projection button and set the projection to NO 
PROJECTION and click Apply 

 

 

Step D: Name the project and display the imagery 

 

 Click the Output tab and in the Project field name the project 

“ 04406110_TC” 

 

 Click the Category button to select the “ Image” model type  

 

 Name the IL ‘TC’ for true color 
 

 Hit the Apply button and then the Close the window 

 

 Repeat Steps C and D for the near infrared 

‘04406110_NIR2’ image (The only difference will be that you’ll 

type in ‘NIR’ in the IL field in the Output window) 
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 To display your imagery click the control panel icon and click on 

the TC_1 infolayer to highlight it  then click the R radio button to 

load the red band. Do this for TC_2 for G and TC_3 for blue to 

load the green and blue bands 

 
I suggest that you display the true color image in the Main tab and the false color near 

infrared image in the Assistant tab. Subsequent products can be displayed on the 

additional screen views. 

 

 To load the NIR imagery in a separate tab click the Assistant tab 

and repeat the steps above for the NIR_1, NIR_2, and NIR_3 bands 

(NIR_1 = R, NIR_2 = G, NIR_3 = B)  

 

 You can attach the images and subsequent screen views so that as you 

navigate through the Main view imagery you can always be looking at the 

same extent in all image screens. To do so use the Attach icon 
in the main tool bar. From the drop down choose the Assistant 

tab. The Main and Assistant tabs are now attached 

 

Click back and forth between the Main tab and the Assistant tab to compare differences 

in the imagery. Note especially how reflective of near-infrared radiation vegetation and buildings are (how red they appear 

in the NIR image). 

 

 

Task 4: Extracting Image Information 

By turning on the Info Cursor  you can extract valuable data and 

create a report of the information from your image.   

 

 Sample the true color and false color imagery at various 

land cover themes in your image (vegetation, water, 

road and bare ground) by clicking on these regions. 

Note: Be sure to keep track of what image and cover 

types you are sampling and in what order, you will 

need to know this for later steps. You can write the 

cover type into the window text before clicking each 

new pixel. The Data Report Window will otherwise 

not keep track of this for you    

 

 The data values for each band (Red, Green, Blue, or 
Near Infrared) will be stored in the Data Report window 

and can be saved in a text file format by clicking Save. Navigate to where you have been saving all previous 

files, name the file Lab5, and click Save 

 

 Inspect the Lab5.txt file for differences in values. It is 

helpful to construct a table in Excel to make quick 

comparisons of pixel values between land cover types and 

band types. 

 

Answer the following question: 

 

1. Based on your tabular or graphic spectral signature data, which 

imagery (false or true color) is best at distinguishing the 4 land 

cover categories you tested for? Why? 
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Task 5: Per Pixel Classification 

 

In this task you will focus on classifying the image using the traditional remote sensing approach of per pixel 

classification. You will not be training the computer in class selection; instead you will perform what is called an 

unsupervised classification  based solely on the pixel values and not the spatial context of the imagery.  You will need to 

use the imagery that you decided has the best distinguishing capabilities between land cover classes in Task 4 (either the 

true color or near infrared imagery). 

 

 In the Main Menu select Image>Classification… 

 

 Click the Create button and in the Context Creation window name 

the classification ‘perpixelclassification’   

 

 Select the Pixel Analysis Type and highlight the band of the image 
you think has the best distinguishing capabilities between land 

cover classes, then click the Apply button 

 

To speed up processing time we’re only going to use one band, so select the 

most appropriate band (Hint: the one with the greatest amount of separation for 

your spectral signatures of land cover classes). In the future you can select 

multiple bands by holding down the Ctrl key while selecting 

 

 Select the ‘perpixelclassification’ by clicking on it and in the band 

Field click on the band you selected in the previous step 

 

 Click the Classification button 

 

 In the Image Classification window select the classifier as 
KMediuns with # Themes to 10 and # Iterations to 1 (for speed 

purposes only)  

 

 Name the classification image ‘perpixelclassification’ and be sure 

the Category is set to Image and click Classify 

 

 

Read over the answers to the following questions pertaining to 
classifications and refer to the Anderson LULC on page 13: 
 

1. What is per pixel classification? 

 

Per pixel classification uses the smallest elements of an image, the pixels, and the spectral values of these pixels. Pixels 

with similar values are grouped together using an algorithm. Statistical information for the classification is based on the 

pixel brightness values only. Classification can be used in thematic maps or can be further incorporated into digital 

analysis. It can be performed on single or multiple image bands to separate areas according to their different scattering or 

spectral characteristics. 

 

2. What's an unsupervised classification? 
 

Unsupervised classification is the categorization of digital image data by computer processing based solely on the image 

statistics without availability of training samples. The classification creates natural groupings in the image values, called  

spectral clusters or classes. In this fashion, values with similar grey levels are assumed to belong to the same cover type. 

The analyst must then determine the identity of these spectral clusters. Principle clustering algorithms include: K-means 

clustering, ISODATA clustering, and Narenda-Goldberg clustering. 

 

3. Which band did you choose to use for your classification?  

 

Near infrared band 1 
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4. What is the general look of the classification? Think about the manual delineations and automated 

delineations you have already performed. 

 

Pixelated, like there is lots of noise in the classification. It would need a lot of filtering to clean it up.  

 

5. Which Anderson Land Use/ Land Cover (LULC) classes are well identified by your unsupervised 

classification? 

 

Water, aquatic vegetation, roads and bare ground. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Task 6: 
Feature 

Based 

Classificatio

n Step 1: 

Segmentatio

n 

 

In this Task 

you will 

produce a 

feature 

based 
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classification. To do so you will need to segment your imagery similar to the procedures used in Lab 4. 

 

 Go to Image>Segmentation to open the Segmentation window 

 

 In the Segmentation window use a Similarity of 10 and an Area (pixels) 

of 1000, and use the same image and band that you used in Task 5 

 

 In the IL field name the segmentation ‘segmentation1’  

 

 We will only segment a subset of the imagery to speed up processing 
time. Click the Bounding box button and enter the values given below: 

 

o X1: 300 

o X2: 600 

o Y1: -100 

o Y2: 0 

  

Click Apply and this process will run for a few minutes, use the time to write up 

your lab. 

 

Task 7: Feature Based Classification Step 2: Feature Based Classification 

 

Use the segmentation you produced in Task 6 to run a feature based classification 

of the same image and band you used in Task 5.  

 

 Go to Image>Classification 

 

 You will need to create a new classification, click Create to open the 

Context Creation window. Name the classification 

'feaurebasedclassi fi cation' 

 

 Click the Regions radio button for the Analysis Type  
 

 Choose an appropriate band to classify, select the feature 

based segmentation you created in Task 6 and then click Apply 

to close the Context Creation window 

  

 With the Classification window still open click the 

‘featurebasedclassi fication’ Context and then click the Extration of 

Attributes of the Regions button. After this process finishes click the 

Classification button to open the Image Classification window 

 

 Use the Isoseg classifier type (this is an unsupervised clasifier), with an 
acceptance treshold of 99.9%. Set the # of Themes to 10 and the # of 

Interactions to 1. Be sure the Category is set to Image and name the 

classification ‘feaurebasedclassi fi cation', then click Classify 

 

 

 
 

Answer the following question: 

 

2. In the feature extraction classification one of the options is to implement image texture, why might you want to do so?  
Discuss the differences you observed between the two unsupervised classifications you produced using the per pixel and 

the feature extraction methods.  Please list the pros and cons of each method. 


