
CEE 317 GeoSurveying 
 

AutoCAD Civil 3D Tutorial: Importing Survey Points 

This tutorial guides you through the basic steps required to (1) import survey data into AutoCAD and 

build a surface, (2) explore representations of a surface, and (3) generate a profile of your surface. 

Part I: Importing Survey Data into AutoCAD 

1. For this tutorial, we will use survey data of a short reach of the Provo River from Utah State 

University.   These survey data include a number of cross sections across the river (points taken 

along the river bed).  The original assignment for Utah State University was developed for 

ArcGIS.  Here, we will explore the data in AutoCAD instead. 

Download the data at this address: 

http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ProvoTopoData.zip 

 After it has downloaded, unzip the data in a location where you have write permission. 

 

2. Open the folder to look at the data included.  The survey data files are saved as ASCII text files.  

There are two here: “st_reach_topo_nez.txt” and “st_reach_wse_nez.txt”.  “NEZ” stands for 

Northing, Easting, Z (elevation).  Open the file “st_reach_topo_nez.txt” in a text editor 

(Notepad++ or Wordpad, or import into Excel). 

 

http://cnr.usu.edu/streamrestoration/files/uploads/Part%202%202010%20Resources/Wheaton_D2_Topo_Excercise.pdf
http://www.gis.usu.edu/~jwheaton/ICRRR/2010/Part_II/ProvoTopoData.zip
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3. You will find that this file has three columns, and these correspond to (1) the Northing, (2) the 

Easting, and (3) the elevation of each point (row).  This file does not tell us the coordinate 

system of the points or the units.  In practice, you would consult with your surveying team to 

obtain the coordinate system and units of these data.  In this example, this information is 

included in a metadata file (“q1523_nw_NAIP2009.txt”) which indicates these are in the 

Universal Transverse Mercator (UTM) projected coordinate system with units of meters. 

 

4. Close any open text files.  We are now ready to import “st_reach_topo_nez.txt” into AutoCAD 

Civil 3D. 

 

5. Launch AutoCAD Civil 3D – English Metric (we know the units are in metric for this example) 

from the Start Menu (as seen below).  Your machine may need to install the software – let it do 

so.  Note: It is important that you launch AutoCAD Civil 3D and not the original AutoCAD.  Civil 

3D has tools that are needed for this exercise that are not found in the original AutoCAD. 
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6. AutoCAD Civil 3D will start.  Close the welcome screen if it appears. 

 

7. We will first create a Surface Definition.  This is where the surveyed points will be stored in the 

database.  On the “Home” ribbon, click Surfaces > Create Surface. 
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8. The Create Surface dialog appears.  Here you can specify the name, description, default contour 

style, and render material for your surface.  You will be able to change the Style and Render 

material later, so don’t worry too much about them right now.  Make sure your screen matches 

the following graphic and click OK. 

 

 

9. Now we have a surface database to store the survey points, but it is currently empty.  Let’s 

import the survey points now.  Click the Modify Tab > Surface 

 

 
 

 

10. The Surface tab now appears.  Click Add Data > Point Files 
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11. The Add Point File dialog appears. 

 

You should first note that there are many different format options in the “Specify point file 

format” window.  Many of these are intuitive: P= point number, N = northing, E = easting, Z = 

elevation, D=description.  You will also note that there are different ways to delimit the file, and 

these include: tab delimited, comma delimited, and space delimited.  From Step 3 (above), you 

should have noted that the format is NEZ, and the columns are separated by a single space. 

 

Hit the plus sign next to the selected files window and browse to “st_reach_topo_nez.txt”.  The 

tool should automatically detect NEZ (space delimited), but if it does not, select it in the file 

format window.  Make sure your screen matches the options below and click OK. 
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12. You may receive a warning that 1 point was outside the elevation extents – this is probably the 

first row, which has a mysterious value of “5182”.  Zoom extents if necessary to see your points. 

 

 
 

AutoCAD is displaying the contours of your surface (1m minor interval, 5m major interval).  You 

can see a meandering river!  The green boundary represents the limits of your surface 

triangulation.  In the next section you will explore ways of visually representing the surface. 

 

Part II: Representing the Surface 

13. Now we will examine different ways to represent the surface.  Click Modify > Surface to arrive at 

the Surface ribbon.  Then click Surface Properties > Surface Properties 
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14. The “Surface style” dropdown provides several ways of visualizing your surface.  We setup the 

surface to display “Contours 1m and 5m”.  How else can we visualize the surface?  First, let’s 

examine the triangulations used to create the surface.  Select “Contours and Triangles” and click 

Apply. 

 

The screen now shows how the surface was created and every triangulation calculation used between 

the survey points.  The more dense the web, the more dense the number of survey points in an area. 

Inspecting this triangulated irregular network (TIN) is especially useful if the generated surface shows 

something unexpected, which may arise due to a surveying error or in areas that are not adequately 

surveyed.  This is an important visualization tool, because it shows the location of your surveyed points 

(at the vertices of the web).  You could surmise that there may be inaccuracies in the locations with less 

survey points. 

You can specify the shape of the boundary used to create this TIN surface.  For example, you may want 

to move the boundary in closer to the river where you have more survey points.  This is left for you as a 

future exercise. 
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15. Now let’s look at a raster-type representation of the surface.  In the Surface Properties dialog, 

select “Elevation Banding (2D)” in the “Surface style” window and click Apply.  AutoCAD should 

display a colorful representation of your surface, as seen below.  We expect the red areas are 

the lowest elevations and the blue areas are the higher elevations, but how can we know for 

sure? 

Note that we can also view a similar map with the slope values (“Slope Banding 2D”). 

16. To answer that question, let’s return to the original representation – select “Contours 1m and 

5m (Background)” and hit Apply.  An easy (and intuitive) way to find the highest elevations and 

lowest elevations is to simply label the contours.  Click Add Labels > Contours – Multiple.  Note 

that there are several options for labeling your surface here. 
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17. Click a point in the top right area and move the mouse.  You will see that a line follows your 

mouse.  All contours that intersect this line will be labeled.   

 

Select a second point (as shown below) and hit enter.  Zooming in, we find the following: 

 

As expected, the slope is draining to the river from both sides (1666 m to 1665 m). 
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18. Now use the contour labeling tool to label the contours in the lower left extent. 

 

 Zoom in after executing this tool, and we find the following: 

 

The contours in the lower left are around 1663 m.  So this verifies that the river is flowing here 

from the top right to the bottom left.  (of course, you could have easily verified this with a field 

trip or a discussion with your survey crew) 

A final note: the contour intervals here seem too large for this dataset.  You can change the 

contour intervals in the Surface Properties dialogue (you will have to create a new style). 
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Part III: Creating a Profile from your Surface 

19. Now that you have created a surface from your survey points and explored different ways of 

representing the surface visually, a useful exercise is to look at profiles (or cross sections) of 

your surface.  This is especially important in design work where you are interested in how the 

topography varies along some path, which is called an alignment in AutoCAD. 

As an example, we will create a profile of the surface along the approximate route of the Provo 

River.  To do this, we first need an alignment, which can be created from a polyline.  Zoom to 

the upper right part of the surface, and then type the command “pl” to start a new polyline.  

Click a point in the river to start the line, and then follow the meandering river, clicking along 

the way to add new vertices (as seen below).  

 

Do your best to follow the low points of the river.  In practice, you would probably want to pick a more 

refined way of tracing the river route, but we will just create the alignment manually here as an 

example. 
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20. Once you have reached the end of the river, hit ENTER to finish the polyline.  Left click on the 

polyline to select it.  Note: if you made a mistake, you can either edit vertices with the polyline 

edit tool (type “pe”) or you can delete the polyline and start over. 

 

 

21. Make sure you are viewing the “Home” ribbon.  With the polyline selected, hit Alignment > 

Create Alignment from Objects.  Hit ENTER if necessary. 
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22. AutoCAD will ask you to verify the direction of the alignment.  As seen below, it will show an 

arrow pointing in the direction (look at the middle part of the polyline).  Because we drew the 

alignment in the direction of the flow, it should be oriented correctly.  Hit ENTER to accept the 

direction or reverse the direction if necessary. 

 

It is important to know the direction of the alignment, as it will help you make sense of the profile.  

Alignments will have stations, such that the alignment begins at a reference point (usually 0+000 m), 

and the stations will be numbered based on the distance along the alignment path from that 

reference point.  So if we specify 0+000 as the starting point of the alignment, a station of 0+500 

signifies a point that is 500 m away from the starting point along the alignment.  Note that this is not 

necessarily the distance from the starting point as the crow flies; alignments that meander (like our 

example) or alignments that have curves/bends will have stations that do not correspond to the 

straight line distance from the starting point of the alignment. 

After you have created your alignment, you can label the stations in your plan view to help you 

remember the orientation.  This is left for you as an exercise on your own. 
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23. After you confirm the direction, a dialog entitled “Create Alignment from Objects” will be 

displayed.  Here you can name the alignment, select the type of alignment, provide a 

description, specify the starting station (we use 0+000.00m here) select the drawing layer and 

specify other options.  Make sure your screen matches the following graphic and hit OK. 

 

24. The alignment is now created.  You can confirm this by looking at the “Prospector” tab in your 

Toolspace.  Expand Alignments > Miscellaneous Alignments and find your new alignment. 
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25. You now have created a surface and your alignment for the river route.  At this stage, the two 

are disjoint.  Let’s sample the surface along the river alignment we just created.  To do this, 

select the alignment in your plan view and click “Surface Profile”.  Here you can select which 

alignment and which surface you want to use in this operation.  In a real project, you would 

likely have many alignments (e.g., road centerlines, pipe centerlines, channel/river centerlines, 

etc) and many surface (e.g., existing grade, proposed grade).  In this example, there is only one 

alignment and one surface. 

 

Highlight “Surface1” and hit “Add>>”.  Then hit OK to sample the surface along your river 

alignment. 
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26. You have sampled the surface along your alignment and are now ready to generate a surface 

profile.  Select your alignment in the plan view and click “Profile View”. 

 

 

27. A “Create Profile View – General” dialogue will be displayed.  You will now go through a series of 

tabs to specify the properties and style of your profile.  Make sure you match the following 

graphic and click “Next >”. 
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28. Once you reach the “Profile View Height” page, ensure that there are values in your minimum 

and maximum height boxes.  If not, then you may not have successfully sampled the surface 

along your alignment (Step 25) or you did not select the correct alignment (Step 27). 

 

For this exercise, we will not worry about the style of the profile, so we will just continue through with the 

default values.  Keep clicking “Next>” until you reach the “Profile Hatch Options” screen, and then hit 

“Create Profile View”. 
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29. AutoCAD will now prompt you to select a profile view origin.  Zoom out and pan away from your 

surveyed points, where you will likely not have any points/features drawn in the future.  Click at 

your desired location to place the profile. 

 

 

30. The profile will be drawn automatically for you, as shown below (red line is your surface).  

Remember that station 0+000 corresponds to the top right corner of the survey, where we 

started the alignment, and station 0+500 is in the lower left corner of the survey.  The profile 

shows the river bed gradually sloping from 0+000 to station 0+500, which meets our 

expectations.  There are some jagged areas, which may have resulted from a variety of reasons: 

(1) we eyeballed the alignment, (2) there may be low points or rocks in the river survey, (3) 

there are locations without many survey points where we are viewing the interpolation.  The 

profile tool is a useful way of looking at slices of your surface, which should inform your designs. 

 

Note that you can also use this tool to generate cross sections (e.g., profiles that are perpendicular to the 

direction of flow).  It is left as an exercise for you to create a cross section of the river. 


